SpamSieve 2.9.15

June 30th, 2014 (SpamSieve)

Version 2.9.15 of SpamSieve is now available. This is a free update that includes the following changes:

  • Works with Apple Mail under Mac OS X 10.9.4. It’s easiest if you update to SpamSieve 2.9.15 before updating to Mac OS X 10.9.4. In any case, if you don’t see the SpamSieve commands in Apple Mail’s Message menu, be sure to choose Install Apple Mail Plug-In from the SpamSieve menu. Otherwise, with the SpamSieve plug-in not installed, Mail will move good messages to the spam mailbox without consulting SpamSieve.
  • Improved compatibility with pre-release versions of Mac OS X 10.10 Yosemite.
  • Made various changes to improve SpamSieve’s filtering accuracy.
  • SpamSieve now requires Mac OS X 10.6.8 or later. Versions of SpamSieve for Mac OS X 10.5 and earlier are available.
  • Modernized lots of code and removed old code that’s no longer needed for compatibility with legacy OS versions.
  • Made changes so that SpamSieve launches faster, especially when cfprefsd is slow to respond.
  • Added the Why are messages marked as spam in Apple Mail but not moved? section to the manual.
  • Fixed a bug that could cause the Install Outlook Scripts command to fail if Parallels Desktop was installed and its stub application for the Windows version of Outlook was enabled.
  • The Apple Mail - SaneBox script now reports errors to Console (since Mail was suppressing them) and no longer times out for very large mailboxes.
  • The Software Update… feature is better at explaining what you can do if installation fails.
  • Adjusted the way the Purchase… window displays the remaining demo time to try to make it clearer.
  • Improved the reporting of file permissions errors and damaged sound files.
  • Improved the handling of localized strings when the application is damaged.
  • Fixed a bug where the release notes in the Software Update… window were shown in the wrong font.
  • Fixed a bug where SpamSieve would auto-train even if you had unchecked all of the filters.
  • Updated the Dutch, Japanese, and Spanish localizations.
  • If you would like to help keep SpamSieve’s Japanese localization up-to-date, please contact spamsieve@c-command.com.

SpamSieve 2.9.15 works with Mac OS X 10.6 through 10.9 and requires an e-mail client. Older versions are available for older operating systems. For information about previous releases of SpamSieve, please see the version history.