The following was posted on the SpamSieve blog:

Version 2.9.35 of SpamSieve is now available.

Save time by adding powerful spam filtering to the e-mail client on your Mac. SpamSieve gives you back your inbox, using Bayesian spam filtering to provide amazing accuracy that’s constantly improving. SpamSieve learns and adapts to your mail, so it’s able to block nearly all the junk—without putting good messages in the spam mailbox. It’s quick and easy to control SpamSieve from within Apple Mail, Airmail, Entourage, MailMate, Mailsmith, Outlook, Postbox 5, PowerMail, and more.

SpamSieve running on your Mac can keep the spam off your iPhone/iPad, and you can even train SpamSieve from your iOS device.

SpamSieve protects your privacy. It does not need access to your mail account login and does not transmit your mail data anywhere. All the processing is done on your Mac.

This is a free update that includes the following changes:

  • Worked around an issue where macOS 10.14 would tell SpamSieve that Mail had finished launching when it hadn’t. If Mail took a long time to launch, this could make SpamSieve erroneously think that its plug-in wasn’t enabled, so it would show some unnecessary and annoying alert windows asking you to fix this.
  • SpamSieve no longer updates its Apple Mail plug-in with each new release because this causes extra work to re-enable it for customers using macOS 10.14. Instead, the plug-in only auto-updates when there is a major change that we recommend for all users. You can still update it manually (by choosing Install Apple Mail Plug-In from the menu) if you want to ensure that you have the latest version.
  • Improved the following sections of the manual:
  • Improved SpamSieve’s error handling when trying to uninstall its Apple Mail plug-in while lacking Full Disk Access.
  • Fixed a bug where AppleScript permissions errors could report the wrong app name.
  • Fixed a bug where some Retina images in the manual were shown at double size.
  • Fixed a bug where the help index file was marked as executable.

SpamSieve 2.9.35 works with macOS 10.7 through 10.14 and requires an e-mail client. Older versions are available for older operating systems. For information about previous releases of SpamSieve, please see the version history.

If you enjoy using SpamSieve, please take a moment to review it on Product Hunt or MacUpdate or to mention it on Twitter, Facebook, or your own site. We’d really appreciate it.