Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 52

Thread: SpamSieve Public Beta and macOS 10.15 Catalina

  1. #21

    Default

    Quote Originally Posted by Michael Tsai View Post
    SpamSieve 2.9.37b1 is now available, with compatibility for Apple Mail under macOS 10.15. Because SpamSieve 2.9.36’s Software Update “Download & Install” command doesn’t work on macOS 10.15, it’s best to update to the beta version of SpamSieve before installing the macOS 10.15 beta on your Mac. You can also click the “Download” button and do the install manually, according to the instructions in the Read Me file.
    Michael,

    I had to reload my entire Mac and running Beta 10.15 now - how do I install the beta? Where do I download it?

    Tony

  2. #22

    Default

    Quote Originally Posted by tonyberinson View Post
    Michael,

    I had to reload my entire Mac and running Beta 10.15 now - how do I install the beta? Where do I download it?

    Tony

    Ignore my last - worked it out.. Michael I also emailed - please ignore.

    Tony

  3. #23

    Default Beta still not working

    I installed the updated version of the beta, but it is causing my mac to go into permanent sleep mode and the only way to wake is to hard reboot. Then when I reloaded, the plug in was removed and does not appear. I totally removed SpamSieve from mac and will not use until the beta is fully vetted.

  4. #24

    Default

    Quote Originally Posted by humanista View Post
    Where can I find the instructions to move my preferences file to the new location for the beta?
    You don’t have to move anything to a new location. SpamSieve will do that for you when it installs the Mail plug-in. The preferences file remains in the normal location.

  5. #25

    Default

    Quote Originally Posted by tonyberinson View Post
    I had to reload my entire Mac and running Beta 10.15 now - how do I install the beta? Where do I download it?
    You can download the release version of SpamSieve from the homepage and then click the link at the top of this thread to enable the built-in Software Update feature to download the beta for you.

  6. #26

    Default

    Quote Originally Posted by okkarl View Post
    I installed the updated version of the beta, but it is causing my mac to go into permanent sleep mode and the only way to wake is to hard reboot.
    Those sounds like macOS issues that should be reported to Apple, as it should be impossible for an app to cause that (and we’ve not heard other reports of it doing so).

  7. #27

    Default IMAP APPEND not working

    I have 3 accounts in Mail and SpamSieve moves all SPAM mail to one folder. I chose a folder on my ATT account. Now, when SPAM email comes in on another account, I am getting the following error message pop up.

    Click image for larger version. 

Name:	Screen Shot 2019-07-24 at 08.47.55.png 
Views:	12 
Size:	75.7 KB 
ID:	746

    I am running the latest Catalina Beta and SpamSieve 2.9.37b1. I never saw this with earlier versions.

  8. #28

    Default

    Quote Originally Posted by jdkite View Post
    I have 3 accounts in Mail and SpamSieve moves all SPAM mail to one folder. I chose a folder on my ATT account. Now, when SPAM email comes in on another account, I am getting the following error message pop up.
    This is not a SpamSieve-specific issue. It indicates a problem with the Mail rule action that moves messages to another mailbox. I recommend reporting this to Apple. You can probably work around it by setting your SpamSieve rule to moves messages to a mailbox under “On My Mac” rather than on the server.

  9. #29

    Default

    Quote Originally Posted by Michael Tsai View Post
    This is not a SpamSieve-specific issue. It indicates a problem with the Mail rule action that moves messages to another mailbox. I recommend reporting this to Apple. You can probably work around it by setting your SpamSieve rule to moves messages to a mailbox under “On My Mac” rather than on the server.
    Thanks. I changed it so each account uses a separate Spam mailbox, so we'll see how that goes.

  10. #30

    Default Still not working

    I removed SpamSieve. Now Mail crashes and will not stay open at all. I will wait. But for now, my mail is not working. I have let Mac beta know of issue.

    Quote Originally Posted by Michael Tsai View Post
    Did you do the Software Update after clicking the link to enable the beta version? Which version are you currently using?

  11. #31
    New Member
    Join Date
    Jul 2019
    Posts
    2

    Default Download from site

    I receive an error message when trying to download the beta through the software update. It asks me to download from the site. I cannot find the link on this site for the Beta.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screen Shot 2019-07-24 at 11.18.32 AM.jpg 
Views:	13 
Size:	27.6 KB 
ID:	747  

  12. #32

    Default

    Quote Originally Posted by asr101 View Post
    I receive an error message when trying to download the beta through the software update. It asks me to download from the site. I cannot find the link on this site for the Beta.
    That’s the issue I mentioned here and in the release notes. You should do Software Update again and click “Download” instead of “Download & Install.”

  13. #33
    New Member
    Join Date
    Jul 2019
    Posts
    2

    Default

    Quote Originally Posted by Michael Tsai View Post
    That’s the issue I mentioned here and in the release notes. You should do Software Update again and click “Download” instead of “Download & Install.”

    Oops - sorry - should have been paying closer attention. Thanks for pointing me in the right direction.

  14. #34

    Default

    I'm on 2.9.37b1 and I had things setup under Catalina working fine.

    My machine just crashed and since the reboot, the plug-in now does not appear in Mail's Manage Plug-Ins. Anyone have any suggestions on how to get it back?

    I'm on Catalina Dev Beta 4 (latest as of this writing).

  15. #35

    Default

    Quote Originally Posted by HunterHillegas View Post
    I'm on 2.9.37b1 and I had things setup under Catalina working fine.

    My machine just crashed and since the reboot, the plug-in now does not appear in Mail's Manage Plug-Ins. Anyone have any suggestions on how to get it back?
    First, please try choosing “Install Apple Mail Plug-In” from the SpamSieve menu. If that doesn’t work, the crash may have messed up Mail’s special DataVaults folder. I suggest deleting it as described at the bottom of this page.

  16. #36

    Default

    Quote Originally Posted by Michael Tsai View Post
    First, please try choosing “Install Apple Mail Plug-In” from the SpamSieve menu. If that doesn’t work, the crash may have messed up Mail’s special DataVaults folder. I suggest deleting it as described at the bottom of this page.
    The re-install didn't help but removing the DataVaults folder did work, back in business. Thanks!

  17. #37

    Default Uninstalled & reinstalled and mail hangs

    I had Catalina installed prior to the new version of SpamSieve, but when I install the latest version of the plug-in, Mail hangs and no new mail will download unless it's completely uninstalled and I do a reboot. Has anyone else had this problem? I trashed the datavault folder, and it didn't help. Any other suggestions?

  18. #38

    Default

    Quote Originally Posted by awisniewski View Post
    I had Catalina installed prior to the new version of SpamSieve, but when I install the latest version of the plug-in, Mail hangs and no new mail will download unless it's completely uninstalled and I do a reboot. Has anyone else had this problem? I trashed the datavault folder, and it didn't help. Any other suggestions?
    I’ve not heard other reports of that. If Mail is hanging, you should record a sample of it. Please include that with the diagnostic report that you send in.

  19. #39
    New Member
    Join Date
    Jul 2019
    Posts
    1

    Default Everything running fine since the newest beta.

    Just wanted to say thank you for the latest beta (2.9.37b1). Ever since it was installed ( 23 July 2019 ), everything (Mail wise) has been running as before. All Is good with macOS Catalina 10.15 Beta 3(?) - and SpamSieve.

    Thanks to all for the fix!

    cheers!
    dan

  20. #40
    New Member
    Join Date
    Aug 2019
    Posts
    1

    Default

    FYI if anyone else is finding that SpamSieve isn't moving Spam messages as expected on the 10.15 beta, what worked for me was to re-do the "SpamSieve - Change Settings" wizard under the message menu. After I did that, the SpamSieve Rule and the "Train As Good"/"Train as Spam" menu items work as expected, putting my Spam in a local Spam folder and returning whitelisted messages to the Inbox.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. DropDMG Public Beta and macOS 10.15 Catalina
    By Michael Tsai in forum DropDMG
    Replies: 2
    Last Post: 06-26-2019, 04:19 PM
  2. EagleFiler Public Beta and macOS 10.15 Catalina
    By Michael Tsai in forum EagleFiler
    Replies: 2
    Last Post: 06-26-2019, 10:28 AM
  3. SpamSieve Public Beta and macOS 10.14 Mojave
    By Michael Tsai in forum SpamSieve
    Replies: 43
    Last Post: 10-23-2018, 03:31 PM
  4. Replies: 4
    Last Post: 06-06-2018, 10:52 AM
  5. SpamSieve Public Beta and macOS 10.12 Sierra
    By Michael Tsai in forum SpamSieve
    Replies: 17
    Last Post: 02-17-2017, 01:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •