Results 1 to 16 of 16

Thread: Mail.app - SS moves good emails to Spam folder

  1. #1

    Default Mail.app - SS moves good emails to Spam folder

    Hi there,

    Quite puzzling this.

    I get some good emails left in the Inbox however I also get the majority of other good emails getting dumped into the Spam folder, despite the logs showing them as good. The have a color of white background as well. I don't have a clue on how to stop his.

    Even this forum registration is marked as good per the following log extract, yet it too was moved to the Spam folder.

    ================================================== ===================
    Predicted: Good (4)
    Subject: Welcome to C-Command Forums!
    From: forums@c-command.com
    Identifier: nf7M1BNEoYnuOOiBQ+30Gw==
    Reason: P(spam)=0.000[0.000], bias=-0.223, R:^nz-out-0506^google^com(0.000), R:^nz-out-0506^google^com(0.000), S:Welcome(0.000), F:Forums(0.001), S:Forums!(0.002), forums!(0.002), rastarr(0.007), XM:vBulletinMailviaPHP(0.022), R:^193^9(0.022), R:^10^114^193^9(0.022), R:^114^193^9(0.022), x-forwarded-for:martin@(0.023), x-forwarded-for:rastarr@(0.023), RP:rastarr(0.023), x-forwarded-to:martin@(0.023)
    Date: 2007-09-06 23:21:15 +1000
    ================================================== ===================
    Trained: Good (Auto)
    Subject: Welcome to C-Command Forums!
    Identifier: nf7M1BNEoYnuOOiBQ+30Gw==
    Actions: added rule <From (address) Is Equal to "forums@c-command.com"> to SpamSieve whitelist, added rule <From (name) Is Equal to "C-Command Forums"> to SpamSieve whitelist, added to Good corpus (704)
    Date: 2007-09-06 23:21:15 +1000
    ================================================== ===================

    The first Mail.app rule is called SpamSieve and matches any 'sender is not in my previous recipients' and moves message to Spam mailbox and marks it as read.

    I don't have any other rules using the Spam folder.

    My corpus is 704 good and 3584 spam messages for 184,157 total words. 5,264 blocklist and 587 whitelist rules. 21 false positives and 35 false negatives - if this is any help. I initially trained it on an enormous amount of spam - no idea if this is causing issues.

    Any ideas? (and I know you'll have them :) )
    Cheers
    Martin
    Last edited by Michael Tsai; 01-15-2008 at 10:38 AM. Reason: Formatting.

  2. #2

    Default

    SpamSieve thought the message was good, so the problem is likely with your Mail setup. Please e-mail me the file:

    /Users/<username>/Library/Mail/MessageRules.plist

  3. #3

    Default SpamSieve Not Keeping Good Messages In Good

    I'm having a related problem. The app is doing fairly well at getting real spam, but my big gripe is that when I am marking a message as good (NOT by hitting Mail's built-in "Junk" button, but the actual menu item that says "SpamSieve - Train as Good..." or whatever), it doesn't seem to be "remembering" this, and I'm constantly having to move good messages that were incorrectly marked. What gives?

  4. #4

    Default

    Quote Originally Posted by gregsgraphics View Post
    it doesn't seem to be "remembering" this, and I'm constantly having to move good messages that were incorrectly marked. What gives?
    Does the log say that SpamSieve is predicting these messages to be spam?

  5. #5

    Default Follow Up

    No. They say "Trained: Good" or "Predicted: Good"

  6. #6

    Default

    Quote Originally Posted by gregsgraphics View Post
    No. They say "Trained: Good" or "Predicted: Good"
    Then SpamSieve didn’t think the messages were spam. Probably one of your non-SpamSieve rules moved the messages.

  7. #7

    Default Follow Up 2

    Weird. Under the Rules 'tab', SpamSieve is the only rule I have active (I have others, but they're unchecked). Wait... under the Junk Mail 'tab', am I supposed to have the "Enable junk mail filtering" option checked? What about "Trust junk mail headers set by my Internet Service Provider"?

  8. #8

    Default

    Quote Originally Posted by gregsgraphics View Post
    under the Junk Mail 'tab', am I supposed to have the "Enable junk mail filtering" option checked? What about "Trust junk mail headers set by my Internet Service Provider"?
    The “Enable…” box should be unchecked, and the other settings in that window don’t matter.

  9. #9

    Default So far, so good.

    I disabled the "Enable junk mail filtering" option as we talked about, and so far it seems to have corrected the issue. So far, so good. Thanks again.

  10. #10

    Default

    I'm having the same problem. Good mail gets thrown in junk with no indication in the log other then it was thought to be good. I enable the built in junk filer as specified here:

    http://c-command.com/spamsieve/manua...cally-deleting

    So that I have a spam mailbox with nice icon and so that I can keyboard shortcut to it with Apple-6. I wonder if there was a recent change that broke those instructions specified above? I'm going to do some more testing.

    Steve

  11. #11

    Default

    Quote Originally Posted by vamp07 View Post
    I enable the built in junk filer as specified here:

    http://c-command.com/spamsieve/manua...cally-deleting

    So that I have a spam mailbox with nice icon and so that I can keyboard shortcut to it with Apple-6. I wonder if there was a recent change that broke those instructions specified above?
    Not that I’m aware of. Do you have any other rules that move messages to the Junk mailbox? You could try going back to the regular setup.

  12. #12

    Default Good messages transferred to Spam Mailbox

    I am suddenly getting a very similar problem, too. I'm using Apple Mail on Leopard. Every time I empty the Spam mailbox, as soon as I click on any other mailbox and then return to the Spam box, a message from one of my regular mailboxes appears there. It is usually a message from the very earliest in the regular box, often 4th from the bottom. It is marked as good, and if I remark it, it has no effect and remains in the Spam box. If I delete it, the original is also deleted. I have no other rules that direct mail into the Spam box, just the one described in the SpamSieve manual. I have two laptops with mailboxes synced via .Mac. This problem only exhibits on one of them - mysterious...!

  13. #13

    Default

    Quote Originally Posted by Graze View Post
    Every time I empty the Spam mailbox
    How are you emptying the Spam mailbox?

    Quote Originally Posted by Graze View Post
    as soon as I click on any other mailbox and then return to the Spam box, a message from one of my regular mailboxes appears there. It is usually a message from the very earliest in the regular box, often 4th from the bottom.
    What does SpamSieve’s log say about this message?

    Also, please make sure that Mail’s built-in junk mail filter is disabled.

    Quote Originally Posted by Graze View Post
    It is marked as good, and if I remark it, it has no effect and remains in the Spam box.
    Have you tried rebuilding the Spam mailbox and your regular mailbox?

  14. #14

    Default Misdirected Mail

    Thanks for your reply. The Apple junk filter is turned off, the log says nothing about the message, until I remark it spam, and I am emptying the spam folder by selecting all and deleting, then finally deleting from trash. Rebuilding the mailboxes seemed to fix it but only temporarily (for about 15 minutes!)

  15. #15

    Default

    Quote Originally Posted by Graze View Post
    Rebuilding the mailboxes seemed to fix it but only temporarily (for about 15 minutes!)
    Then the problem seems to be with Mail’s database. It might help to quit Mail and delete the file:

    /Users/<username>/Library/Mail/Envelope Index

    Mail will then try to reconstruct a new database when launched.

  16. #16

    Default

    Thank you so much, Michael, that seems (touch wood!) to have solved the problem.

Similar Threads

  1. Can't rename Spam mailbox in Mail.app
    By Roph in forum SpamSieve
    Replies: 1
    Last Post: 08-17-2007, 10:20 PM
  2. Replies: 2
    Last Post: 08-11-2007, 02:12 PM
  3. Replies: 2
    Last Post: 06-25-2007, 08:35 PM
  4. "Train as Spam" moves messages to wrong folder
    By MacMaarten in forum SpamSieve
    Replies: 1
    Last Post: 01-10-2007, 06:37 AM
  5. Entourage Good-Mail move to Proper Folder?
    By Mike Mack in forum SpamSieve
    Replies: 5
    Last Post: 11-20-2006, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •