Results 1 to 15 of 15

Thread: Spam not going to spam folder

  1. #1
    New Member
    Join Date
    Oct 2015
    Posts
    1

    Default Spam not going to spam folder

    I just upgraded my Mac to ElCapitan and now SpamSieve seems to have stopped moving spam to the spam folder.

    I still have the menu options in MacMail to train as spam or good.

    But when I mark emails as spam, they do not move.

    Any advice would be much appreciated.

    Thanks

  2. #2

    Default

    Quote Originally Posted by drstir View Post
    I just upgraded my Mac to ElCapitan and now SpamSieve seems to have stopped moving spam to the spam folder.
    Please check the setup in Mail to make sure that your SpamSieve rule is still in place.

    Quote Originally Posted by drstir View Post
    I still have the menu options in MacMail to train as spam or good.

    But when I mark emails as spam, they do not move.
    Please check the Console for any errors from Mail or SpamSieve.

  3. #3

    Default Spam failed to move

    I have the same problem since moving to El Captain: The filter works, but the "Train as Spam" - fails to move chosen email to Spam folder. Yes, the Rule is in place....

  4. #4

    Default

    Quote Originally Posted by archmac View Post
    I have the same problem since moving to El Captain: The filter works, but the "Train as Spam" - fails to move chosen email to Spam folder.
    Please check the Console for any errors from Mail or SpamSieve.

  5. #5

    Default Spam failed to Move

    I'm having the same problem. Here are the log excerpts:

    10/5/15 2:22:22.583 PM adam[65227]: SpamSieve Apple Mail Plug-In [Train as Spam] Error Training: Mail got an error: Can’t get mailbox "INBOX" of account "Law E-Mail".
    10/5/15 2:22:53.647 PM adam[65235]: SpamSieve Apple Mail Plug-In [Train as Spam] Error Training: Mail got an error: Can’t get mailbox "INBOX" of account "Law E-Mail".
    10/5/15 2:32:49.561 PM Mail[65566]:
    Loaded Mail Version 9.0 (3094)
    OS X Version 10.11 (15A284)
    Installed Bundles:
    /Users/xxxx/Library/Mail/Bundles/MailActOn.mailbundle (3.2.1b1971)
    /Users/xxxx/Library/Mail/Bundles/SpamSieve.mailbundle (1.8.3)
    10/5/15 2:32:55.034 PM Mail[65566]: SpamSieve Mail Plug-In: Launching via launch agent failed.
    10/5/15 2:32:55.228 PM SpamSieveHelper[65586]: Performance: Please update this scripting addition to supply a value for ThreadSafe for each event handler: "/Library/ScriptingAdditions/SIMBL.osax"
    10/5/15 2:34:14.461 PM adam[65631]: SpamSieve Apple Mail Plug-In [Train as Good] Error Training: Mail got an error: An error of type 8 has occurred.
    Thanks for your help.

    Adam
    Last edited by Michael Tsai; 10-06-2015 at 09:23 AM. Reason: Formatted.

  6. #6

    Default

    Quote Originally Posted by agarson View Post
    10/5/15 2:22:22.583 PM adam[65227]: SpamSieve Apple Mail Plug-In [Train as Spam] Error Training: Mail got an error: Can’t get mailbox "INBOX" of account "Law E-Mail".
    From what I’ve seen, errors like this are caused by two interacting bugs:

    1. Updating to Mac OS X 10.11 sometimes causes Mail to create a duplicate IMAP account where one didn’t exist before. The new account is marked as inactive, so you wouldn’t ordinarily see it unless you go to the Accounts section of Mail’s Preferences window.
    2. If you have two accounts with the same name (the Description field), Mail’s AppleScript support (which SpamSieve uses to move trained messages) can get confused and report that error when the script tries to reference a message in the inbox.


    The workaround is to either rename or delete the inactive account so that all of your accounts then have unique names.

  7. #7

    Default

    Quote Originally Posted by Michael Tsai View Post
    From what I’ve seen, errors like this are caused by two interacting bugs:

    1. Updating to Mac OS X 10.11 sometimes causes Mail to create a duplicate IMAP account where one didn’t exist before. The new account is marked as inactive, so you wouldn’t ordinarily see it unless you go to the Accounts section of Mail’s Preferences window.
    2. If you have two accounts with the same name (the Description field), Mail’s AppleScript support (which SpamSieve uses to move trained messages) can get confused and report that error when the script tries to reference a message in the inbox.


    The workaround is to either rename or delete the inactive account so that all of your accounts then have unique names.
    Thank you. I removed disabled and redundant accounts, which fixed half the problem. Now messages in the Inbox marked as "Spam" are moved to the Spam folder; however, messages in the Spam Folder marked as "Good" remain in the Spam Folder. The console generates an Error 8 message. Any suggestions?

    Adam

  8. #8

    Default Now messages in the Inbox marked as "Spam" are moved to the Spam folder

    Quote Originally Posted by agarson View Post
    Thank you. I removed disabled and redundant accounts, which fixed half the problem. Now messages in the Inbox marked as "Spam" are moved to the Spam folder; however, messages in the Spam Folder marked as "Good" remain in the Spam Folder. The console generates an Error 8 message. Any suggestions?

    Adam
    Worked for me, Thanks

  9. #9

    Default

    Quote Originally Posted by archmac View Post
    Worked for me, Thanks
    Are you still having problems training messages as good? I had one other customer who would get the error:

    SpamSieve Apple Mail Plug-In [Train as Good] Error Training: Mail got an error: An error of type 8 has occurred.
    However, he said that the same redundant accounts fix worked for that error as well as the one when training as spam.

  10. #10
    New Member
    Join Date
    Oct 2015
    Posts
    2

    Default I have the same problem

    My spam is not able to be trained.

    I have visited Console, and have the following message:

    7/10/2015 8:10:57.221 AM Arthur[652]: SpamSieve Apple Mail Plug-In [Train as Spam] Error Training: Mail got an error: Can’t get mailbox "INBOX" of account "....".

    I do not have any duplicated or redundant accounts, and SpamSieve is picking up 'normal' spam, I am just not able to train as spam.

  11. #11

    Default

    Quote Originally Posted by Arthur View Post
    7/10/2015 8:10:57.221 AM Arthur[652]: SpamSieve Apple Mail Plug-In [Train as Spam] Error Training: Mail got an error: Can’t get mailbox "INBOX" of account "....".

    I do not have any duplicated or redundant accounts, and SpamSieve is picking up 'normal' spam, I am just not able to train as spam.
    I have not heard of anyone else in that situation. Please send in a screenshot of the Accounts section of Mail’s preferences and tell me the name of the account in the error message. Thanks!

  12. #12

    Default

    Quote Originally Posted by Arthur View Post
    I do not have any duplicated or redundant accounts, and SpamSieve is picking up 'normal' spam, I am just not able to train as spam.
    Thanks for sending the screenshot. It looks like the account mentioned in the error message is a duplicate. There are an active POP account and an inactive IMAP account that have the same name. There are also two other pairs of duplicated accounts. I recommend that you rename the inactive ones to have “Inactive” in their Description field so that Mail doesn’t get confused.

  13. #13
    New Member
    Join Date
    Oct 2015
    Posts
    2

    Default

    Quote Originally Posted by Michael Tsai View Post
    Thanks for sending the screenshot. It looks like the account mentioned in the error message is a duplicate. There are an active POP account and an inactive IMAP account that have the same name. There are also two other pairs of duplicated accounts. I recommend that you rename the inactive ones to have “Inactive” in their Description field so that Mail doesn’t get confused.
    Brilliant, many thanks. All working now.

  14. #14
    New Member
    Join Date
    Apr 2016
    Posts
    1

    Default

    Quote Originally Posted by Arthhur View Post
    Brilliant, many thanks my page https://skinnyexpress.com/phen375-review-and-results with the phen375 review is working now.
    I checked the console and I'm not getting any errors but my spam still isn't going to the spam folder.
    Last edited by Kloak; 11-30-2016 at 08:51 AM.

  15. #15

    Default

    Quote Originally Posted by Kloak View Post
    I checked the console and I'm not getting any errors but my spam still isn't going to the spam folder.
    Please see this page.

Similar Threads

  1. Replies: 3
    Last Post: 07-17-2014, 10:56 AM
  2. Spam trained as good ends up back in spam folder.
    By dflowerz in forum SpamSieve
    Replies: 3
    Last Post: 11-05-2013, 10:04 PM
  3. Replies: 3
    Last Post: 12-10-2012, 10:23 PM
  4. Replies: 2
    Last Post: 08-27-2008, 09:42 PM
  5. Replies: 6
    Last Post: 09-24-2006, 04:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •