Results 1 to 10 of 10

Thread: El Capitan performance issues

  1. #1

    Default El Capitan performance issues

    Anyone else having significant performance issues since upgrading to 10.11 (El Capitan)? Flagging mail as spam seems to result in a large amount of resource (CPU) load. We've been having trouble and I don't think it's our mail server, and Apple remoted to our machines for over an hour to determine it doesn't seem to be Mail. Now as I'm reading the SpamSieve forums, I'm wondering if SS is the culprit. Don't get me wrong - SS has been a GREAT product and we've used it for years ... we're just interested in getting feedback so we know where the hit is coming from.

  2. #2

    Default

    Quote Originally Posted by dbrom View Post
    Anyone else having significant performance issues since upgrading to 10.11 (El Capitan)? Flagging mail as spam seems to result in a large amount of resource (CPU) load.
    I’m not seeing that here, and judging from customers who have written in it does not seem to be a common problem. Is it Mail or another process that has high CPU load? How long does it last? The first thing I would do is sample that process during the period of high CPU use to see what it’s doing. Then e-mail me the files, and I’ll take a look.

    There do seem to be lots of general performance issues with Mail in Mac OS X 10.11, unrelated to SpamSieve, although they seem to mostly go away after it’s been running for a while.

  3. #3

    Default Rule missing?

    Hi Michael -

    Does SpamSieve work differently w/ rules in El Capitan? I noticed the previous mail rule for SpamSieve is completely missing.

  4. #4

    Default

    Quote Originally Posted by dbrom View Post
    Does SpamSieve work differently w/ rules in El Capitan? I noticed the previous mail rule for SpamSieve is completely missing.
    No, but sometimes Apple Mail loses its rules when you update the OS.

    I didn’t hear back from you about the CPU use problem. Is that still occurring?

  5. #5

    Default

    Hi Michael,

    I am also encountering the CPU usage problem, Mail.app hangs when I try to flag something as Spam to SpamSieve. I captured a sample of the SpamSieve process while Mail.app is hanging for you, it's attached to this post.

    If there is any other information which would be helpful for you to identify the problem let me know and I can get it.

    Thanks!
    Attached Files Attached Files

  6. #6

    Default

    Quote Originally Posted by sbnicholas View Post
    I am also encountering the CPU usage problem, Mail.app hangs when I try to flag something as Spam to SpamSieve. I captured a sample of the SpamSieve process while Mail.app is hanging for you, it's attached to this post.
    If Mail is hanging, you should sample Mail rather than SpamSieve.

  7. #7

    Default

    Next time Mail.app hangs I'll grab a sample. It seems to be stable for now.

  8. #8

    Default

    Quote Originally Posted by Michael Tsai View Post
    No, but sometimes Apple Mail loses its rules when you update the OS.

    I didn’t hear back from you about the CPU use problem. Is that still occurring?
    The CPU load is reproducible whenever 1 or more messages are manually flagged as spam.

    How can I recreate the SpamSieve rule in Mail preferences? Should I completely uninstall/reinstall SpamSieve?

    I really appreciate your quick replies.

  9. #9

    Default

    Quote Originally Posted by dbrom View Post
    The CPU load is reproducible whenever 1 or more messages are manually flagged as spam.
    OK, then please sample Mail during that time.

    Quote Originally Posted by dbrom View Post
    How can I recreate the SpamSieve rule in Mail preferences?
    You can just set it up again as shown in Step 3 of the instructions.

  10. #10

    Default

    I did not hear back from either dbrom or sbnicholas, so I’m assuming that the problem is resolved.

Similar Threads

  1. Replies: 3
    Last Post: 10-02-2015, 04:10 PM
  2. El Capitan AppleScript/JXA error
    By RISCfuture in forum SpamSieve
    Replies: 3
    Last Post: 10-02-2015, 10:41 AM
  3. Question on performance
    By comradedata in forum EagleFiler
    Replies: 2
    Last Post: 05-30-2007, 02:34 PM
  4. Performance with big libraries
    By reinard in forum EagleFiler
    Replies: 2
    Last Post: 05-30-2007, 02:28 PM
  5. Import performance
    By joelorr in forum EagleFiler
    Replies: 12
    Last Post: 05-30-2007, 12:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •