Results 1 to 4 of 4

Thread: (Possibly?) Odd Behaviour Capturing from Preview (Saved vs. Unsaved? First time?)

  1. #1

    Default (Possibly?) Odd Behaviour Capturing from Preview (Saved vs. Unsaved? First time?)

    Hi Michael -- just sending you some info in case it's of use to you.

    Tried to use F1 to capture from Preview today, only to get an error message that directed me to this page:

    http://c-command.com/blog/2009/12/28...-from-preview/

    I read the post, but it stated that all should be well in Mavericks. (I'm 10.9.5, and EagleFiler 1.6.4)

    Confused, I tried again. No luck.

    Then I realized the document I was trying to capture from Preview had not yet been saved as a file, so thought that might be the problem.

    Opened an existing file in Preview, used F1 to capture to EageleFiler -- and...success.

    Was about to accept that I could only use F1 in Preview to capture previously-saved documents, when I thought I'd try it one more time with my unsaved file. Lo and behold, it now worked.

    So, unless I've mis-remembered the chain of events, I wonder if there's something whereby the first attempt to capture from Preview using F1 will fail IF the document you're trying to capture has not yet been saved?

    Just spit-balling, here, but thought I should bring my experience to your attention in case it points out anything to you from a coding/bug perspective.

    Thanks.

  2. #2

    Default

    Quote Originally Posted by sammy View Post
    Then I realized the document I was trying to capture from Preview had not yet been saved as a file, so thought that might be the problem.
    Thanks for the report. Yes, EagleFiler can only capture if the document is saved to disk. You are right that the error message is misleading. I will address that in the next version. I’m not sure why it would work for you the second time if the document was still unsaved.

  3. #3

    Default

    Quote Originally Posted by Michael Tsai View Post
    I’m not sure why it would work for you the second time if the document was still unsaved.
    After reading your message I've tried to repeat that, but have been unsuccessful. So, either there's something unexpected going on, or else I made an error in my original testing. I would assume the latter.

    Thanks Michael.

    P.S. There won't be a way to do this in the future, I'm assuming? Just in case, here's my use case. Looking at a document in an application (could be a browser, could be some random utility, etc.) and decide I want to save a PDF of the document or image or screen or whatever to my EagleFiler library. I have a Keyboard Maestro workflow that quickly 'prints' to an unsaved PDF in Preview, and from their I would like to capture it to EagleFiler without first saving to a file, and without saving to EF's 'To Import' folder in Finder. (In EagleFiler's preferences I already have my 'Web Page Format' set to PDF, which technically covers my use-case for browsers -- although even then, sometimes the version of the page you get by selecting to 'Print' it is somewhat different than the version of the page that you would capture directly.)

    Hopefully that makes some sense. Let me know if you'd like any additional clarification. Thanks.

  4. #4

    Default

    Quote Originally Posted by sammy View Post
    There won't be a way to do this in the future, I'm assuming?
    Preview is barely scriptable as it is, so I’m not aware of a way. In the general case, it’s not possible for EagleFiler to get at the data if it’s not saved. For Web browsers, it can get the URL and fetch the page itself, although as you noted sometimes this produces different results than the browser due to different login state.

Similar Threads

  1. Drone behaviour
    By qnc in forum SpamSieve
    Replies: 1
    Last Post: 12-21-2013, 02:51 PM
  2. Trojans Saved as False Negatives
    By Dick in forum SpamSieve
    Replies: 2
    Last Post: 05-05-2013, 03:21 PM
  3. Password not being saved
    By schartman in forum SpamSieve
    Replies: 1
    Last Post: 12-02-2008, 11:54 AM
  4. Odd behaviour...(or not?)
    By cutter44 in forum SpamSieve
    Replies: 3
    Last Post: 10-11-2007, 06:32 PM
  5. Replies: 3
    Last Post: 04-15-2007, 02:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •