Results 1 to 6 of 6

Thread: IMAP Spam Stays in Inbox

  1. #1
    Unregistered
    Guest

    Default

    I get email from a particular server. I have one account set up in Mail so that it downloads all the messages in POP and leaves a copy on the server, and I also have another account set up so that it can view and manage all the email on that server through IMAP. I have the trial of SpamSieve set up. It sends all the spams to the Spam folder (as recommended).

    What seems to be happening is that the spams that are downloaded through the POP account are correctly filtered out as spam and sent to the Spam folder and I can see them there, but when I look into the IMAP account, the same spams are still in the inbox, and I have to manually Train as Spam, which sends them to the Spam folder.

    I admit: my way of looking at this email might be problematic, but I haven't had any problems getting the email and working with it.

    It just seems to be a problem for SpamSieve. Any suggestions?
    Last edited by Michael Tsai; 09-22-2006 at 12:11 AM. Reason: Moved to a new thread.

  2. #2

    Default

    Quote Originally Posted by Unregistered View Post
    What seems to be happening is that the spams that are downloaded through the POP account are correctly filtered out as spam and sent to the Spam folder and I can see them there, but when I look into the IMAP account, the same spams are still in the inbox, and I have to manually Train as Spam, which sends them to the Spam folder.
    I haven't seen that configuration before. :-)

    It's possible that your rules are setup such that SpamSieve isn't being applied to the IMAP messages. Is the SpamSieve rule at the top of the list? You could try disabling your POP account and then see if it filters the IMAP messages correctly. If not, then the setup is at fault.

    If they do filter properly when the POP account is disabled, then you've probably managed to confuse Mail by having it download the same messages twice. In that case, there isn't really anything I can do for you. SpamSieve itself doesn't care where the messages come from or if it sees the same message twice; the issue is whether Mail will apply the rule that lets SpamSieve see the messages.

  3. #3
    Unregistered
    Guest

    Default I think it worked

    Thanks, I disabled the POP account and only found one spam this morning, so I think it worked.

    I admit I'm ignorant, but could you tell me one thing about IMAP mail in Mail: What I'm trying to do is use IMAP so I can work with my email "live" from any machine but at the same time get Mail to download all the messages so they reside on my hard drive on my main computer so I have a local backup. Can I do that? If so, what settings do I use in Mail to do that? I am using Mail 2.0.

    The only reason I was accessing this server through both IMAP and POP was to get that local backup.

    Thanks very much.

  4. #4
    Unregistered
    Guest

    Default About the setup

    Oh, btw, the SpamSieve rule was the first one underneath the "News from Apple" rule when I looked. I moved it up to the very top at the same time that I disabled the POP account.

  5. #5

    Default

    Quote Originally Posted by Unregistered View Post
    I admit I'm ignorant, but could you tell me one thing about IMAP mail in Mail: What I'm trying to do is use IMAP so I can work with my email "live" from any machine but at the same time get Mail to download all the messages so they reside on my hard drive on my main computer so I have a local backup. Can I do that?
    Yes, you can do that with IMAP. In Mail's account preferences, select your account. Click the Advanced tab. Then make sure that "Keep copies of messages for offline viewing" says "All messages and their attachments."

  6. #6
    Unregistered
    Guest

    Default Thanks so much.

    Much better now!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •