Results 1 to 8 of 8

Thread: Lost a bunch of files!

  1. #1

    Default Lost a bunch of files!

    After using EagleFiler for almost a year, I suddenly got a popup notice announcing a mess of missing files. In Eaglefiler itself, each of these files says: "This Web archive could not be displayed; perhaps the file is damaged or missing."

    I saw another thread here that talked about having moved the files in Finder or other possibilities, but none of those seem to fit. The only way I accessed them is through Eaglefiler.

    Please tell me what to do. Or what not to do. I'm really frightened that I'll lose more somehow.

    I've just upgraded to 1.4.6. Was using 1.4.5 when this happened.

    --Heidi

  2. #2

    Default

    Quote Originally Posted by hfw View Post
    After using EagleFiler for almost a year, I suddenly got a popup notice announcing a mess of missing files.
    Each time you open the library, EagleFiler verifies that it can find all the files. There are basically two reasons you would see this error message:

    1. You (or a program on your Mac) moved/renamed/deleted the files or a containing folder without doing so through EagleFiler’s interface.
    2. Your hard drive is damaged so that the files are no longer there.


    A Spotlight search should be able to tell you whether the files are elsewhere on your Mac. If so, you can move them back into the proper location and EagleFiler will be happy. Otherwise, you would need to restore them from a backup.

  3. #3

    Default

    Thanks for your response...

    As it turns out all of the "missing" files were files I'd put into a folder I'd created in Eaglefiler. They were also all tagged. I'd done the moving from within Eaglefiler, just as I had with several other folders whose files still show up.

    The good news is that the files were all undamaged, but I don't understand what went wrong, or what could have been different about this folder.

    Only two errors remain. Both appear to be folders within Eaglefiler. One is the EQ6 folder that was the problem child. The other is Trash. The option of revealing those in the library to delete does not show up in the error window, and selecting them in Eaglefiler doesn't let me do anything either.

    --Heidi

  4. #4

    Default

    Quote Originally Posted by hfw View Post
    The good news is that the files were all undamaged, but I don't understand what went wrong, or what could have been different about this folder.
    Perhaps there was some sort of unexpected disk error. If you send me EagleFiler’s log file:

    /Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

    I’ll take a look.

    Quote Originally Posted by hfw View Post
    Only two errors remain. Both appear to be folders within Eaglefiler. One is the EQ6 folder that was the problem child. The other is Trash. The option of revealing those in the library to delete does not show up in the error window, and selecting them in Eaglefiler doesn't let me do anything either.
    The Trash folder should be directly within the Files folder. You can move it into place using the Finder. The EQ6 must be a folder that you created. The Reveal In Library button seems to be working on my Mac, so I’m not sure why it isn’t for you. I suppose you could search within EagleFiler to find where EagleFiler expects the EQ6 folder to be.

  5. #5

    Default

    Okay... found the EQ6 folder in Finder and deleted it. No more error there.

    A trashcan shows up at the bottom of the Records section in Eaglefiler, as it always has. I created a Trash folder in General>Files and now, happily, the Error window is empty.

    I will send the log in a minute or two.

    I notice that the folders that show up in Eaglefiler are actually the other libraries I created. Should there be any problem with creating a folder within a library (say, General) and dragging files within Eaglefiler to it?

    --Heidi, who is really impressed with your rapid responses!

  6. #6

    Default

    Quote Originally Posted by hfw View Post
    Okay... found the EQ6 folder in Finder and deleted it. No more error there.
    I would not expect that to help. If EagleFiler can’t find the folder, the remedy is either to delete the folder in EagleFiler (so that it stops looking for it) or to move it to the correct location in the Finder (so that EagleFiler can find it). In this case, EagleFiler expected the EQ6 folder to be in the Files folder.

    Quote Originally Posted by hfw View Post
    I will send the log in a minute or two.
    It looks like there may be a bug where EagleFiler gets confused if you remove the search field from the toolbar. While I look into this, I recommend configuring your toolbar so that the search field is present and visible.

    Quote Originally Posted by hfw View Post
    I notice that the folders that show up in Eaglefiler are actually the other libraries I created.
    I’m not quite sure what you mean, but it’s incorrect to have one library inside of another.

    Quote Originally Posted by hfw View Post
    Should there be any problem with creating a folder within a library (say, General) and dragging files within Eaglefiler to it?
    You can drag files and folders between two EagleFiler windows. Does that answer your question?

  7. #7

    Default

    Quote Originally Posted by Michael Tsai View Post
    It looks like there may be a bug where EagleFiler gets confused if you remove the search field from the toolbar.
    This is fixed in EagleFiler 1.4.7.

  8. #8

    Default

    Thanks! I'll give it a try.

    --Heidi

Similar Threads

  1. Lost serial Number
    By flan in forum SpamSieve
    Replies: 1
    Last Post: 03-30-2008, 04:39 PM
  2. Spam Sieve has lost its accuracy on my Macs
    By tuqqer in forum SpamSieve
    Replies: 21
    Last Post: 02-27-2008, 01:44 PM
  3. Two lost files in EagleFiler
    By abusch in forum EagleFiler
    Replies: 1
    Last Post: 01-27-2007, 02:35 PM
  4. lost notes
    By thoresson in forum EagleFiler
    Replies: 2
    Last Post: 11-08-2006, 06:53 AM
  5. SpamSieve PowerMail 5.5 link lost
    By Zelemenos in forum SpamSieve
    Replies: 5
    Last Post: 10-31-2006, 04:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •