Previous Next  Up  Table of Contents  SpamSieve 2.9.27 Manual  Technical Support

7.2.1   Sending in an Error Report

If an error window appeared on your screen, please include the exact text of the error message in your e-mail. (It may help to use Copy and Paste.)

Please also send in any errors that were reported in the system log. The sections below describe different ways to do this depending on which version of macOS you have.

On macOS 10.12 and Later

  1. From SpamSieve’s Help menu, choose Save Diagnostic Report… at the bottom. (If you can’t launch SpamSieve to access its Help menu, see below.)
  2. Choose a location such as your desktop and click Save. Saving the report may take a minute or so.
  3. Create an e-mail to spamsieve@c-command.com and drag the Diagnostic Report.tbz file into the e-mail message to include it as an attachment/enclosure.

On macOS 10.12 and Later, If You Can’t Launch SpamSieve

  1. Click on Finder in the Dock.
  2. From the Go menu, choose Utilities.
  3. Double-click the Console application.
  4. Click on your Mac under Devices at the left side of the window. (It may be necessary to first choose Show Sources from the View menu.)
  5. From the Action menu, choose All Messages. Make sure that Include Info Messages and Include Debug Messages are both unchecked.
  6. If Activities is selected (blue) in the toolbar, click it to turn off activities mode.
  7. If the main part of the window shows any recent error messages, select them (or choose Edit ‣ Select All).
  8. There are two ways to share the selected part of the log with us:
    • Easier: Click the Share button in the toolbar and select Mail. (If you do not use Apple Mail as your mail client, you can instead Copy and Paste the log messages into your mail client.)
    • Preferred: Choose Edit ‣ Copy. Open TextEdit and Paste the text into a new plain text document. Save the TextEdit document to disk and attach it to your e-mail message.

On Mac OS X 10.11 and Earlier

  1. Click on Finder in the Dock.

  2. From the Go menu, choose Utilities.

  3. Double-click the Console application.

  4. Click on All Messages at the left of the window. (It may be necessary to first click the Show Log List toolbar button if you don’t see All Messages at the left.)

  5. If it shows any recent error messages, select them (or choose Edit ‣ Select All).

    Note: You may need to click the Earlier button at the bottom of the window to find errors that did not occur recently.

  6. Choose File ‣ Save Selection As… and save the file as My Log.log on your desktop.

  7. Drag this file into your e-mail message to include it as an attachment/enclosure.

Previous Next  Up  Table of Contents  SpamSieve 2.9.27 Manual  Technical Support