Results 1 to 12 of 12

Thread: Hang while indexing (after import problems)

  1. #1

    Default Hang while indexing (after import problems)

    Well I finally took the plunge and decided to move my entire Documents folder into Eaglefiler. During the import there were a large number of errors, mostly claiming that there was already a file of that name or contents in the library. In most cases, this was not true. However, there is no way to select and copy or to save the contents of the Error window, so details will have to wait (I had the same behavior on my other computer and hope to be able to give you more information about this later.)

    I left my computer for a time and when I came back there were messages on the screen that both Eaglefiler AND OSX had crashed; had to cold boot.

    After rebooting, I wanted to check how successful the import had been. I opened EagleFiler. First it opened two libraries that I had moved to the system trash. This seems wrong to me--I put them in the trash so they wouldn't be found by Eaglefiler but were still available if I want to restore them later.

    I stopped the activities in activity viewer and closed both those libraries. Then opened the one to which I had imported my Documents. Indexing for it hung at "172 of 2948" saying it would take 30 seconds to complete indexing. After several minutes of "EagleFiler not responding" I force quit. But not before taking a sample, which I'm sending directly to you.

    Any idea what the problem might be? I suppose I should start over and add folders one at a time rather than trying to import everything in one swell foop.

    Stan

  2. #2

    Default

    Quote Originally Posted by stanh View Post
    During the import there were a large number of errors, mostly claiming that there was already a file of that name or contents in the library. In most cases, this was not true.
    If EagleFiler says that a file is a duplicate, I think you can be sure that there’s another file in the library with identical contents (and you can use the Reveal In Library button to see it). I’ve never heard of EagleFiler getting this wrong. I’ll send you a pre-release build that makes it more clear which files are duplicates. (Also, it’s worth noting that you can tell EagleFiler to allow duplicates.)

    Quote Originally Posted by stanh View Post
    However, there is no way to select and copy or to save the contents of the Error window, so details will have to wait
    Sorry about that. Right now you can only copy one error at a time. I’ll be improving this in the next release.

    Quote Originally Posted by stanh View Post
    After rebooting, I wanted to check how successful the import had been. I opened EagleFiler. First it opened two libraries that I had moved to the system trash. This seems wrong to me--I put them in the trash so they wouldn't be found by Eaglefiler but were still available if I want to restore them later.
    I think it’s a feature that EagleFiler can track your libraries when they move. If you don’t want it to re-open a library, you can close the library before quitting EagleFiler or hold down Shift when launching EagleFiler.

    Quote Originally Posted by stanh View Post
    Indexing for it hung at "172 of 2948" saying it would take 30 seconds to complete indexing. After several minutes of "EagleFiler not responding" I force quit. But not before taking a sample, which I'm sending directly to you.
    Indexing hung, but did EagleFiler itself hang? You say that you force-quit it, but from the sample log it doesn’t look like EagleFiler was hung. Usually if the indexing hangs you can click the x button to cancel it, and EagleFiler’s log file will say which file(s) it was indexing when you cancelled. Also, before cancelling, you could check Activity Monitor to see if there are any eftexttool or efindextool processes and sample them.

    Quote Originally Posted by stanh View Post
    Any idea what the problem might be? I suppose I should start over and add folders one at a time rather than trying to import everything in one swell foop.
    If the library has all of the files imported, all you need to do is make sure they get indexed. You could try opening the library again and see if it finishes the indexing, or you could rebuild the index.

    If the files were not all imported into the library, it might be easier to create a new library rather than try to figure out what was imported and what wasn’t.

  3. #3

    Default

    Okay--thanks for the detailed explanations.

    I've now re-imported the contents of the Documents folder into a new library by importing just a few at a time for a total of over 8,000 items.

    But I had to "OK" at least 200 variations on the following error:

    ValueError: filedescriptor out of range in select()

    What does this mean? I have checked several folders and all the documents seem to be there, but I haven't had time to check everything yet. And why do I have to ok each of these individually instead of having them appear in the Errors window? Maybe there's something I need to know here?

  4. #4

    Default

    Quote Originally Posted by stanh View Post
    But I had to "OK" at least 200 variations on the following error:

    ValueError: filedescriptor out of range in select()

    What does this mean?
    If you get an error that appears in an alert instead of in the Errors window, it’s probably reported as an “Internal Error.” This means that the error was unexpected, which is why EagleFiler doesn’t have a plain-English description of what went wrong. An internal error usually indicates a bug in EagleFiler or an unusual OS or hardware failure, e.g. if you disconnected a disk that EagleFiler was using.

    In this case, the error has something to do with EagleFiler doing too many things at once, and running into an OS limit. Did you import the files using the capture key? The version that I sent you includes a fix for a bug that could lead to this error if you imported a large number of files using the capture key (rather than, say, using drag and drop).

    Quote Originally Posted by stanh View Post
    I have checked several folders and all the documents seem to be there, but I haven't had time to check everything yet.
    If there’s an internal error, the files that you see in the library window are probably stored correctly, but there may have been files that were not imported and that were not reported in the Errors window. Thus, I recommend creating a new library and re-importing the files. With the version that I sent you, it should be possible to do this in one batch.

  5. #5

    Default

    Thank you for sending me the new version. I installed it, created a new library, and dragged all the folders in my documents folder to the drop pad. I left the machine alone for some time. When I returned it appeared that all the files had been added to the library. There was an Error window open with a long list of duplicates which I would liked to have investigate. However, Eaglefiler was "not responding". I couldn't open Eaglefiler's Activity Viewer. Thinking it might still be indexing, I left it alone. I have no idea how long it was in this state before I came back to my computer, but I let it go for at least another 30 minutes. I tried to do some other work outside of Eaglefiler, but very quickly the computer froze. Nothing would resopnd to mouse or keyboard. I had to cold boot.

    Is there something I should try before going through the process again?

    Thanks,

    Stan

  6. #6

    Default

    Also, the Activity Viewer has two separate progress bars labeled "Copying tags to Spotlight comments." As I have just created this library and imported the documents, there are no tags assigned other than Unread. Under the first progress bar it now says "About 16 minutes". It started out saying "About 7 minutes" and has been going up ever since. Likewise with the second bar, which now reads "About 6 hours, 6 minutes"--earlier it was "2 hours" and some minutes.

    Should I just let it cook as long as it likes?
    Also, Quicksilver crashed. It has crashed several times during my attempts to get the documents into Eaglefiler. It has never crashed before under any circumstances. I am sending an Activity Monitor sample just in case it's helpful.

  7. #7

    Default

    The "progress" bars are up to 46 minutes and "About 17 hours, 58 minutes" so I'm going to kill the process--this can't be right.

  8. #8

    Default

    Quote Originally Posted by stanh View Post
    However, Eaglefiler was "not responding". I couldn't open Eaglefiler's Activity Viewer. Thinking it might still be indexing, I left it alone. I have no idea how long it was in this state before I came back to my computer, but I let it go for at least another 30 minutes. I tried to do some other work outside of Eaglefiler, but very quickly the computer froze. Nothing would resopnd to mouse or keyboard. I had to cold boot.
    If this happens again, could you send me a screenshot of the process list in Activity Monitor? Do you see anything abnormal, like one application using a lot of RPRVT memory or a lot of CPU time? From the sample that you sent, it doesn’t look like EagleFiler’s main thread was stuck, or that it was using a lot of CPU time. So I’m not sure why it wasn’t responding—and, of course, even if it were stuck it shouldn’t be possible for it to freeze the whole computer.

    One odd thing I noticed is that it appears to be waiting for the Finder (to read a Spotlight comment). I wonder if the Finder was also stuck. You might try turning off the preference to copy the tags into the comments.

    Since you said, earlier, that Quicksilver and OS X itself also crashed, I wonder if there might be a problem with your RAM. I suggest checking it with memtest.

    Also, I see that you have a third-party input manager installed. I doubt that it’s the cause of these problems, but it might be worth trying the import in a fresh OS X user account to see if that can narrow down where the problem is.

    Quote Originally Posted by stanh View Post
    Also, the Activity Viewer has two separate progress bars labeled "Copying tags to Spotlight comments."
    It’s a bug that there are two of these, but it shouldn’t cause any particular problem other than being slightly slower. The whole process should take just a couple minutes, at most, on an Intel Mac. The reason it’s taking so long seems to be that the Finder isn’t responding.

  9. #9

    Default

    Thanks for the suggestions. I'm leaving town tomorrow for a week, so I'll follow up when I get back and have time to try these things out.

  10. #10

    Default

    I managed to try things out before leaving.

    - Memtest says "all tests passed".

    - Created a fresh user accound and imported the documents folder into a new library under that account by selecting all 20 folders at once and dragging to the drop pad. Of the 20, 7 were not imported, reporting: "Internal Error While Adding". The others appear to be okay but I have not had time to do a thorough check. I turned off writing tags to spotlight comments. I did this whole thing twice with identical results (same 7 folders not imported).

    Please post suggestions and I'll try them when I get back. Thank you.

  11. #11

    Default

    Quote Originally Posted by stanh View Post
    Of the 20, 7 were not imported, reporting: "Internal Error While Adding".
    Please e-mail me the log file:

    /Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

  12. #12

    Default

    Quote Originally Posted by stanh View Post
    But I had to "OK" at least 200 variations on the following error:

    ValueError: filedescriptor out of range in select()
    This is fixed in EagleFiler 1.2.1 (which also improves the duplicate reporting and makes it easier for you to allow duplicate files).

Similar Threads

  1. Some problems using the new release
    By dmc in forum EagleFiler
    Replies: 6
    Last Post: 05-30-2007, 02:13 PM
  2. problems updating to version 2.6
    By mistral in forum SpamSieve
    Replies: 2
    Last Post: 03-20-2007, 09:54 AM
  3. Mail.app continuing problems
    By ajanjigian in forum SpamSieve
    Replies: 3
    Last Post: 02-02-2007, 08:06 PM
  4. Mail.app problems
    By ajanjigian in forum SpamSieve
    Replies: 18
    Last Post: 01-26-2007, 06:08 PM
  5. Problems with stability
    By dmc in forum EagleFiler
    Replies: 3
    Last Post: 12-06-2006, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •