PDA

View Full Version : Only some SS rules work



Blacksmith
05-16-2007, 10:44 AM
I'm using v2.6.2 with Entourage 2004.

I've created two SpamSieve rules a per the manual p42, as I want to apply other filing rules to my email after they've been checked for spam content. So far, spam identification and the moving of spam to the Junk folder works a treat so thanks for that, Michael!

I've placed my own filing rules below the two SpamSieve rules in the rules list.

The filing system only half works in that only some of my filing rules fire whereas others don't and I can't figure out where it's going wrong. All my filing rules filters "any criteria is met" and apply that to "where FROM contains" followed by part of the sender's email address, e.g. I have An Apple rule set for "@euromailer.lists.apple.com" + "@applenews.lists.apple.com", etc. This works perfectly.

My Microsoft rule is an example that doesn't work and the only difference from the Apple rule is in the sender's address which is "@newsletters.microsoft.com". I've double-checked the sender's address and my Microsoft originated newsletters all have the form someone@newsletters.microsoft.com, so where I am I going wrong?

BTW, I have a catch all rule placed last of all in my rules list and that correctly fires.

Michael Tsai
05-16-2007, 11:38 AM
My Microsoft rule is an example that doesn't work and the only difference from the Apple rule is in the sender's address which is "@newsletters.microsoft.com". I've double-checked the sender's address and my Microsoft originated newsletters all have the form someone@newsletters.microsoft.com, so where I am I going wrong?


Does this rule work if you select a message and apply the rule manually using Message > Apply Rule? What about if you use Message > Apply Rule > All Rules?

If you choose Tools > Mailing List Manager, do you have any rules there? Perhaps one of them is preventing the normal Entourage rules from being applied to these messages.

Blacksmith
05-16-2007, 03:51 PM
Does this rule work if you select a message and apply the rule manually using Message > Apply Rule? What about if you use Message > Apply Rule > All Rules?

If I select a message then apply the correct rule to it, that works - the message is moved to the appropriate folder. If I select a message and apply All Rules, it sometimes works. If I select a group of messages, e.g. all today's unread mail in the Inbox, and apply All Rules, this never works. I have to select messages individually and apply a single rule.


If you choose Tools > Mailing List Manager, do you have any rules there? Perhaps one of them is preventing the normal Entourage rules from being applied to these messages.

There are no rules listed in Mailing List Manager.

Michael Tsai
05-16-2007, 04:37 PM
If I select a message then apply the correct rule to it, that works - the message is moved to the appropriate folder. If I select a message and apply All Rules, it sometimes works.

Then I suggest you try unchecking the rules above it until you find which one is interfering.

Blacksmith
05-17-2007, 05:22 AM
Then I suggest you try unchecking the rules above it until you find which one is interfering.

I unchecked them all then started from the top edited each rule then checking it again. I saw nothing obvious so didn't change anything but things seem to be working this morning!

Thanks for your support, Michael.