PDA

View Full Version : Mark as Read



my8Bmg
05-03-2007, 01:15 PM
I am using SpamSieve to put spam in my Apple Mail's "Junk" mailbox. I followed all of the directions found here:

http://c-command.com/spamsieve/manual-ah/automatically-deleting

The question I have is: Is it possible to have Junk mail marked as read so that I don't have that "unread messages" number alerting me to new messages in Junk mail? I figure, if it's junk, it's junk.

I'm doing a 30 day trial of SpamSieve and as of day 2 it's pretty great. If I can get this kink worked out I'll be purchasing for sure.

Thanks!

Michael Tsai
05-03-2007, 01:31 PM
The question I have is: Is it possible to have Junk mail marked as read so that I don't have that "unread messages" number alerting me to new messages in Junk mail?

Yes, you can add an action (http://c-command.com/spamsieve/manual-ah/marking-incoming-spam-m) to your “SpamSieve” rule that marks the messages as read.

epalton
09-27-2007, 11:46 AM
Hi,

I tried adding that action to the Mail rule but it ends up marking all new messages as read, not just the spam ones. Am I doing something wrong?

My "SpamSieve" rule is:

If ANY of the following conditions...
[Every Message]

Perform:
[Move Message] to mailbox [Spam]
[Mark as Read]

-----

Thanks.

Michael Tsai
09-27-2007, 12:01 PM
I tried adding that action to the Mail rule but it ends up marking all new messages as read, not just the spam ones.

I’ve never heard of that happening before. Which version of Mac OS X do you have? Are you sure that your SpamSieve rule is working? If it isn’t called “SpamSieve”, Mail will apply the actions to every message, not just the ones that SpamSieve thinks are spam.

epalton
09-27-2007, 12:10 PM
Michael,

Thanks for the fast reply.

I'm sure the rule is called "SpamSieve" and it is working. I get spam diverted to my "Spam" folder regularly.

I'm using Mail 2.1.1 (752.3) and Mac OS 10.4.9.

I'm new to Mail having switched from Entourage a few days ago, for what that's worth.

Thanks.

Michael Tsai
09-27-2007, 12:58 PM
I'm sure the rule is called "SpamSieve" and it is working. I get spam diverted to my "Spam" folder regularly.


Could you e-mail me the file (eaglefiler@c-command.com):


/Users/<username>/Library/Mail/MessageRules.plist

so that I can look into this?

epalton
09-27-2007, 04:18 PM
Michael,
I apologize but it must have been a temporary glitch on my end. It's working properly now. If it happens again I'll revisit this forum.
Thanks again for the fast response.