PDA

View Full Version : Thunderbird - moving junk to junk folder



Egidio
03-29-2007, 03:14 PM
I was wondering if there is any setting that I'm forgetting to set in order to get messages marked as junk to move to my junk folder. I noticed that SpamSieve marks those messages correctly, but they stay in my inbox. It'd be nice to have them move to my junk mail folder.

Michael Tsai
03-29-2007, 04:35 PM
I was wondering if there is any setting that I'm forgetting to set in order to get messages marked as junk to move to my junk folder. I noticed that SpamSieve marks those messages correctly, but they stay in my inbox. It'd be nice to have them move to my junk mail folder.

Thunderbird has settings, described a bit here (http://c-command.com/spamsieve/manual-ah/installing11), to control whether incoming spam messages and manually marked spam messages are moved to the Junk folder. There is a bug in SpamSieve 2.6 such that manually marked spam messages remain in the inbox regardless of the setting in Thunderbird. This will be addressed in a maintenance update soon.

Michael Tsai
04-09-2007, 01:19 PM
This is fixed in SpamSieve 2.6.1 (http://c-command.com/blog/2007/04/09/spamsieve-261/).

Egidio
04-10-2007, 11:06 AM
Michael,

I've re-checked my settings after installing this update. Still when I click on a message and mark it as spam, it stays in my inbox. Shouldn't it move to the junk folder or simply be deleted? If I manually mark a message as spam, it could be deleted automatically.

Michael Tsai
04-10-2007, 11:31 AM
Still when I click on a message and mark it as spam, it stays in my inbox. Shouldn't it move to the junk folder or simply be deleted?

Yes, it should do whatever you’ve configured Thunderbird to do. Which version of Thunderbird are you using? Please note that you may need to adjust the settings for all your accounts, as well as for Local Folders. Also, you may need to go into the Config Editor in Thunderbird’s Advanced preferences. There are a variety of junk/spam settings there, such as “moveOnSpam”.

Egidio
04-10-2007, 12:09 PM
Yes, it should do whatever you’ve configured Thunderbird to do. Which version of Thunderbird are you using? Please note that you may need to adjust the settings for all your accounts, as well as for Local Folders. Also, you may need to go into the Config Editor in Thunderbird’s Advanced preferences. There are a variety of junk/spam settings there, such as “moveOnSpam”.

I'm using the latest 2.0.0.0 RC 1. Maybe that's the problem. All settings have been re-checked. I don't use Local Folders. Only have one POP and one IMAP account. In both of those when I mark a message as spam, it gets marked but not moved. I'll check on the Advanced preferences, but I'm afraid it might be like reading Greek, which is a language I'm not proficient on. :)

Michael Tsai
04-10-2007, 01:11 PM
I'm using the latest 2.0.0.0 RC 1. Maybe that's the problem.

It works for me with 2.0rc1, but I did have to go into the Config Editor. It had disabled the “move to junk” mailbox feature when it upgraded my settings from 1.5.

Egidio
04-11-2007, 06:07 PM
It works for me with 2.0rc1, but I did have to go into the Config Editor. It had disabled the “move to junk” mailbox feature when it upgraded my settings from 1.5.

Maybe that happened to me. I checked my about:config, though, and couldn't see what might be causing the problem I'm having. When I entered "spam" on the about:config section, I was presented with several settings. All of them had "true." If I may impose on your patience again, what setting was it that you had to change? Maybe I'm missing that.

Michael Tsai
04-11-2007, 06:50 PM
what setting was it that you had to change?

I have the following set to true: mail.spam.manualMark, mail.server.default.moveOnSpam, mail.server.server1.moveOnSpam (etc. for other servers). All the spamActionTargetAccounts are set to “mailbox://nobody@Local%20Folders” and the spamActionTargetFolders are set to “mailbox://nobody@Local%20Folders/Spam”. (I have a top-level local folder called “Spam”.) Also, mail.spam.manualMarkMode is set to 0 and mail.spam.version is set to 1. I’m not sure how much of this is necessary, but this is how I’ve set it, and it works.

Egidio
04-11-2007, 11:25 PM
Michael,

Thank you for your valuable reply. I do appreciate the time you took to provide me such detailed response. I made one change in my settings based on what you sent. I'll see next time I get a message that I have to manually mark as spam and see what happens. I'll probably have to wait to see how this will work on my POP account. I think that SpamSieve will not move messages if the account is IMAP. Anyway, thanks again. I'll report back what happens.

Michael Tsai
04-12-2007, 08:54 AM
I think that SpamSieve will not move messages if the account is IMAP.

Why not? I just tried it with IMAP, and it seems to work fine.

Egidio
04-15-2007, 07:12 PM
Still no luck. I noticed in your settings, your junk mail folder is called "Spam." Does it matter for SpamSieve what the name really is? My IMAP calls the spam folder Junk. I've made sure the settings on the IMAP server move messages to that folder, but whenever I manually mark a message as spam, it just sits in that inbox. Since I use IMAP, I can probably simply wipe out TBird from my Mac and install a clean copy, including a new plist file and user profile. I'm beginning to think that maybe some extensions in TBird could be causing this problem for me. It's not a big deal, really, since SpamSieve still moves spam automatically. It's just the manual setting that is not working as expected.

Michael Tsai
04-15-2007, 10:18 PM
I noticed in your settings, your junk mail folder is called "Spam." Does it matter for SpamSieve what the name really is?


No, in fact SpamSieve doesn’t even know what mailboxes you have in Thunderbird. What matters is that Thunderbird is configured to move the messages to a folder that actually exists. I recommend checking the URLs in the config editor, because I’ve seen cases where it’s set to use a non-existent mailbox.



My IMAP calls the spam folder Junk. I've made sure the settings on the IMAP server move messages to that folder, but whenever I manually mark a message as spam, it just sits in that inbox.


Well, I don’t think that Thunderbird would care which folder your server-side spam filter is using. But, just to keep things simple, how about configuring Thunderbird to use a separate folder (perhaps even a local one) so that we can be sure there isn’t any interference?

Egidio
04-20-2007, 04:37 PM
Michael,

Thanks again for your help. After triple checking the entries in my configuration, I thought the problem was a corrupted profile. So, I created a new profile in TBird. Everything is working perfectly well. Now, when I click on a message and mark it a spam, it is deleted immediately (as it was before). SpamSieve is working well, too, and with incredible accuracy (98.7% correct).

Michael Tsai
04-20-2007, 08:13 PM
So, I created a new profile in TBird. Everything is working perfectly well.

Great—thanks for the follow-up.