PDA

View Full Version : "Train as Spam" moves messages to wrong folder



MacMaarten
01-10-2007, 06:20 AM
Last month, I installed the trial version of SpamSieve, set it up in Apple Mail following the standard instructions and was amazed by it's accuracy. Spam has become less of an issue for me. Great! Thank you, Michael!

After I purchased a license, I decided to revamp the installation a bit. I re-enabled Mail's built-in Junk folders, disabled the actual Junk filter and had SpamSieve drop off all spam into the Junk folders. Works like a charm. Now I have the benefits that I can (1) see which accounts were spammed with what spam, (2) erase the spam with the single keystroke Cmd-J and best of all (3) search globally without spam showing up in the results.

However, the "Train as Spam"-command in the Message-menu moves the culprit message to the wrong spambox. In the first installation, I had a folder called 'Spam' living in the root. When I revamped the setup, I deleted that folder but I still have a sub-folder called 'Spam' (which I use to script-move messages sent to invalid e-mail addresses of my domain), and that's where my manually marked messages end up now.

System: Apple PowerMac DP G5, MacOS 10.4.8, Apple Mail 2.1, SpamSieve 2.5

Any way to cure this behaviour?

MacMaarten
01-10-2007, 06:37 AM
Ahem, I'd better get a good night's sleep first.

I found the answer to my question sitting in my Messages-menu. It was an item called "Change Settings".

It now works as expected!