PDA

View Full Version : Prevent images from loading in Apple Mail?



gmaletic
11-07-2006, 06:20 PM
I have been using Apple Mail for a long time, but decided to give SpamSieve a try because the Apple Mail junk filter doesn't seem to be cutting it any longer. So far, so good, but one thing I miss is that when Apple Mail flags an e-mail as "junk" it automatically prohibits images from being dynamically loaded when you take a look at the e-mail. (You have to click the "Load Images" button to get around this restriction.) Is there any way for me to set a similar restriction on the "Spam" folder that SpamSieve places my junk mail in?

Thanks.

Michael Tsai
11-07-2006, 06:54 PM
I believe setting SpamSieve to use Mail's Junk mailbox (http://c-command.com/spamsieve/manual-ah/automatically-deleting) will have the desired effect.

gmaletic
11-07-2006, 08:25 PM
Thanks for the suggestion, though to my surprise, it seems as if the "Spam" folder I created as a result of configuring SpamSieve already exhibits this behavior (i.e., doesn't show images.) If for some reason I'm not correct, I'll try your suggestion.

Thanks!

Michael Tsai
11-07-2006, 10:45 PM
Yes, actually I think that the Spam folder does already work because SpamSieve tells Mail that the messages are junk. I was assuming that for some reason that wasn't working for you; Mail will also prevent the images from loading if the messages are in the Junk mailbox.

Kabeyun
04-22-2008, 01:43 PM
I'm also having problems with inline images in mail messages. I went through 2 tiers of Apple tech support, and it occurred to me that it could be SpamSieve.

My problem: no images appear at all, in any mailbox. Strangely, the SPAM mailbox I set up when I originally installed SpamSieve is the only mailbox that even offers a Load Images button when a message with missing images is selected. However, clicking it does nothing. Neither does ctrl-click-Download Images. Dragging an imageless, buttonless message to the SPAM folder does not enable a Load images button (not that the button would work).

"Display remote images in HTML messages" is selected.

Help much appreciated.

-K

Michael Tsai
04-22-2008, 01:57 PM
I'm also having problems with inline images in mail messages.


The other posters in this thread were asking for a way to hide images. You seem to want to see them, so I don’t think that this is at all the “same problem.”


My problem: no images appear at all, in any mailbox. Strangely, the SPAM mailbox I set up when I originally installed SpamSieve is the only mailbox that even offers a Load Images button when a message with missing images is selected. However, clicking it does nothing.

SpamSieve does not affect the way Mail loads images. All it does is control whether they’re hidden by default (i.e. whether the Load Images button is shown). So the source of your problem is elsewhere.

Since Apple apparently doesn’t know what’s causing the problem, either, perhaps you should create a fresh Mac OS X user account (or entire OS X installation) and rebuild starting from a setup that works.