SpamSieve 2.9.12

December 16th, 2013 (SpamSieve)

Version 2.9.12 of SpamSieve is now available. This is a free update that includes the following changes:

  • Works with Apple Mail under Mac OS X 10.9.1. It’s easiest if you update to SpamSieve 2.9.12 before updating to Mac OS X 10.9.1. In any case, if you don’t see the SpamSieve commands in Apple Mail’s Message menu, be sure to choose Install Apple Mail Plug-In from the SpamSieve menu. Otherwise, with the SpamSieve plug-in not installed, Mail will move good messages to the spam mailbox
  • On Mac OS X 10.9 Mavericks, Apple Mail is slower at moving messages to the Spam mailbox when you choose SpamSieve - Train as Spam. SpamSieve includes a workaround to move messages faster by using GUI scripting instead of regular AppleScript. To enable the workaround, please see the AppleMailTrainSpamGUIScripting option in the Esoteric Preferences section of the manual.
  • Versions 1.2.1 and later of the Airmail e-mail client include support for SpamSieve. The Setting Up Airmail section of the manual describes how to use SpamSieve with Airmail.
  • It is now possible to set up a spam filtering drone using the MailMate e-mail client. This is described in the Setting Up a MailMate Drone section of the manual.
  • The Flash PowerMate feature is now compatible with (and requires) version 3.0 of the Griffin PowerMate software.
  • You can now hold down the Option key when you click Check Now in the Software Update… window to always download the latest version, even if your version is already up-to-date. This is an easy way to download and re-install a fresh copy of SpamSieve if yours is damaged.
  • Added the AppleMailTrainGoodClearFlags esoteric preference, for people who use colored flags on their spam messages for purposes other than indicating the spam level.
  • If Microsoft Outlook is not able to retrieve a message’s source, SpamSieve will now log the message’s subject to Console.
  • Worked around an OS bug that could cause a crash when SpamSieve was processing certain types of multi-part e-mail messages.
  • Improved various error messages.
  • Tried to work around a crash by disabling JavaScript in the release notes view.

SpamSieve 2.9.12 works with Mac OS X 10.5 through 10.9 and requires an e-mail client. Older versions are available for older operating systems. For information about previous releases of SpamSieve, please see the version history.